UPS Elevated Error Rate and Response Times
Incident Report for EasyPost
Resolved
Response times and error rates have returned to normal.
Posted 4 months ago. Sep 26, 2018 - 21:45 PDT
Monitoring
Issue with the upstream API appears to be resolving itself. Engineers are monitoring the situation.
Posted 4 months ago. Sep 26, 2018 - 21:30 PDT
Investigating
We are experiencing elevated error rates and response times when communicating with UPS. Engineers are investigating.
Posted 4 months ago. Sep 26, 2018 - 21:18 PDT
This incident affected: API.