Canada Post error rate
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted 3 months ago. May 06, 2018 - 08:32 PDT
Investigating
We are currently investigating an increase in the number of errors for rating and label requests to CanadaPost.
Posted 3 months ago. May 06, 2018 - 01:15 PDT
This incident affected: API.