Address Verification Upstream Issues
Incident Report for EasyPost
Resolved
Address verification is now functioning normally.
Posted 4 months ago. Sep 21, 2018 - 17:23 PDT
Identified
An upstream provider for our Address Verification service is experiencing issues and is investigating.
Posted 4 months ago. Sep 21, 2018 - 16:05 PDT
This incident affected: API.