Network Connectivity Issues
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted Feb 10, 2017 - 13:57 PST
Monitoring
Connectivity is to be fully restored. Engineers are monitoring.
Posted Feb 10, 2017 - 13:23 PST
Investigating
Engineers are investigating connectivity issues to our primary datacenter
Posted Feb 10, 2017 - 13:17 PST