APC Tracking Outage
Incident Report for EasyPost
Resolved
This incident has been resolved
Posted about 1 month ago. May 21, 2018 - 19:12 PDT
Identified
APC is experiencing an issue down stream that is impacting tracking. We are working with the carrier to resolve this.
Posted about 1 month ago. May 21, 2018 - 09:25 PDT
This incident affected: API.