Canada Post Label Issues
Incident Report for EasyPost
Resolved
Engineers have deployed a fix and Canada Post label creation is working
Posted 3 months ago. May 28, 2019 - 22:44 PDT
Investigating
Engineers are investigating an elevated error rate creating Canada Post labels
Posted 3 months ago. May 28, 2019 - 21:52 PDT
This incident affected: API.