DPD UK is currently conducting essential maintenance
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 10, 2018 - 16:07 PST
Identified
The carrier DPD UK is currently performing essential maintenance, resulting in an increased error rate when EasyPost uses DPD UK services.
Posted 6 months ago. Feb 10, 2018 - 11:22 PST