Australia Post Failures
Incident Report for EasyPost
Resolved
Australia Post services have been restored.
Posted 3 months ago. Sep 06, 2017 - 18:44 PDT
Investigating
Engineers are investigating an issue with Australia Post. It appears to be downstream and we have emailed for an update.
Posted 3 months ago. Sep 06, 2017 - 08:04 PDT