DHL eCommerce domestic (Global Mail) Outage
Incident Report for EasyPost
Resolved
DHL GlobalMail (eCommerce) has resolved the outage and label purchasing services have been restored.
Posted 9 days ago. Oct 08, 2017 - 17:15 PDT
Identified
The issue has been identified and DHL is working to resolve this outage.
Posted 9 days ago. Oct 08, 2017 - 14:13 PDT
Investigating
Engineers are currently investigating an outage with DHL GlobalMail (eCommerce) on label purchasing services.
Posted 9 days ago. Oct 08, 2017 - 13:22 PDT