Australia Post Continued Failures
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted 2 months ago. Sep 11, 2017 - 08:24 PDT
Identified
Australia Post has identified the problem and we are working to resolve it with them.
Posted 2 months ago. Sep 08, 2017 - 12:04 PDT
Investigating
Engineering is continuing to monitor the issue with Australia Post. It appears to be downstream and we have emailed for an update.
Posted 3 months ago. Sep 06, 2017 - 20:38 PDT