Elevated error rates from DPD
Incident Report for EasyPost
Resolved
Everything is stable at this time
Posted 29 days ago. Jun 21, 2018 - 06:21 PDT
Monitoring
DPD shipment rating and purchasing is back to normal performance; engineers are still monitoring
Posted 29 days ago. Jun 21, 2018 - 06:06 PDT
Investigating
Engineers are currently investigating slow performance and elevated error rates when purchasing or rating shipments using DPD
Posted 29 days ago. Jun 21, 2018 - 05:54 PDT
This incident affected: API.