ParcelForce Rate Requests Failing
Incident Report for EasyPost
Resolved
The issues with rating ParcelForce shipments has been resolved.
Posted 21 days ago. Mar 28, 2019 - 19:10 PDT
Identified
We have identified the issue and are working on a resolution currently.
Posted 23 days ago. Mar 26, 2019 - 16:35 PDT
Investigating
Rate requests to ParcelForce are currently failing. Engineers are investigating the issue
Posted about 1 month ago. Mar 18, 2019 - 09:30 PDT
This incident affected: API.