Canadapost Outage
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 26, 2018 - 16:53 PDT
Identified
Canadapost has been experiencing an ongoing outage since approximately 20:00 PDT. EasyPost engineers have engaged with the carrier's support team and are investigating.
Posted 3 months ago. Aug 25, 2018 - 23:42 PDT