SpeeDee Rating Elevated Error Rates
Incident Report for EasyPost
Resolved
The carrier is no longer returning an elevated number of errors. We will continuing to monitor the carrier's performance.
Posted 5 months ago. Mar 26, 2019 - 16:04 PDT
Identified
We are currently experiencing elevated error rates with SpeeDee rating.
Posted 5 months ago. Mar 26, 2019 - 12:49 PDT
This incident affected: API.