Payment Problems
Incident Report for EasyPost
Resolved
Stripe's API is back up
Posted 11 days ago. Sep 11, 2018 - 17:25 PDT
Identified
Our payment processor, Stripe, is currently experiencing an outage and credit card payment processing is delayed.
Posted 11 days ago. Sep 11, 2018 - 17:16 PDT
This incident affected: API and Website.