CanadaPost Error Rate
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted about 1 month ago. May 17, 2018 - 03:55 PDT
Investigating
We are currently investigating an increase in the number of errors for requests to CanadaPost.
Posted about 1 month ago. May 17, 2018 - 02:58 PDT
This incident affected: API.