FedEx Elevated Error Rate and Response Times
Incident Report for EasyPost
Resolved
The issues communicating with the FedEx API have been resolved.
Posted May 30, 2020 - 17:42 PDT
Monitoring
The error rate from the FedEx API has subsided and response times are returning to normal.
Posted May 30, 2020 - 16:51 PDT
Identified
We are again experiencing elevated error rates and response times coming from the FedEx API. Engineers are taking steps to mitigate impact.
Posted May 30, 2020 - 16:29 PDT
This incident affected: EasyPost Backend (API, Tracking).