USPS Rating Issues
Incident Report for EasyPost
Resolved
This incident has been resolved
Posted Jan 15, 2020 - 18:37 PST
Monitoring
Engineers have implemented a fix for the USPS rating issue and are monitoring the system.
Posted Jan 15, 2020 - 18:27 PST
Investigating
Engineers are currently investigating issues rating some USPS parcels
Posted Jan 15, 2020 - 17:36 PST
This incident affected: EasyPost Backend (API).