UPS Elevated Error Rates
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted 5 months ago. May 23, 2018 - 08:06 PDT
Monitoring
UPS errors appear to have subsided. Engineers are continuing to monitor.
Posted 5 months ago. May 23, 2018 - 07:44 PDT
Investigating
Engineers are investigating elevated error rates when communicating with UPS.
Posted 5 months ago. May 23, 2018 - 07:34 PDT