Australia Post Label Purchasing Outage
Incident Report for EasyPost
Resolved
Australia Post has listed all systems as operational again.
Posted Jul 13, 2017 - 08:34 PDT
Identified
Please be advised that Australia Post is currently experiencing issues with their printing of labels. Their support teams are currently working to resolve the issue as soon as possible.
Posted Jul 12, 2017 - 19:17 PDT