Batch Jobs Delayed
Incident Report for EasyPost
Resolved
All queues are caught up
Posted about 1 month ago. Aug 21, 2018 - 10:40 PDT
Investigating
Some batch and asynchronous jobs are delayed. Engineers are investigating.
Posted about 1 month ago. Aug 21, 2018 - 07:19 PDT
This incident affected: API.