USPS Test Server Down

Incident Report for EasyPost

Resolved

Endicia has restarted their test server. The issue is resolved.
Posted Mar 24, 2014 - 15:06 PDT

Identified

Endicia's test server, our USPS provider, is down. We don't have an ETA on when it will be live again.

The production server is still live and you're able to purchase shipping.
Posted Mar 24, 2014 - 14:41 PDT