Issues purchasing USPS postage
Incident Report for EasyPost
Resolved
This incident has been resolved.
Posted May 20, 2017 - 21:49 PDT
Monitoring
Engineers have rerouted network traffic and USPS postage should be working normally at this time.
Posted May 20, 2017 - 20:39 PDT
Investigating
Engineers are currently investigating an issue purchasing USPS postage
Posted May 20, 2017 - 20:18 PDT