DHL GLobalMail is not responding
Incident Report for EasyPost
Resolved
DHL GlobalMail has informed us service should be restored. Label purchasing has returned to normal.
Posted 12 months ago. Apr 14, 2018 - 20:00 PDT
Update
It appears the downstream service is down. We have reached out and are currently monitoring the situation. Shipment purchases will be unavailable until service is restored.
Posted 12 months ago. Apr 14, 2018 - 18:52 PDT
Investigating
We are noticing errors purchasing labels from DHL GlobalMail. Engineers are investigating.
Posted 12 months ago. Apr 14, 2018 - 18:22 PDT