Issue Uploading Labels
Incident Report for EasyPost
Resolved
Label purchasing has been stable for 90 minutes; this incident is fully resolved
Posted Jul 19, 2017 - 19:46 PDT
Identified
Engineers have rolled back the problematic code; label purchasing should be functional now
Posted Jul 19, 2017 - 18:13 PDT
Investigating
Engineers are investigating an issue uploading label images to our blob store
Posted Jul 19, 2017 - 18:01 PDT