USPS international rating failing
Incident Report for EasyPost
Resolved
The issues with rating international USPS shipments has been resolved.
Posted 7 months ago. Jan 26, 2019 - 17:28 PST
Update
We are continuing to work on a fix for this issue.
Posted 7 months ago. Jan 26, 2019 - 17:27 PST
Identified
An issue has been identified with rating international shipments using USPS.
Posted 7 months ago. Jan 26, 2019 - 17:08 PST
This incident affected: API.