Degraded UPS API performance

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Nov 29, 2023 - 12:56 PST

Monitoring

Error rates from the UPS API have returned to normal. Our engineers will continue to monitor the performance of the UPS API.
Posted Nov 29, 2023 - 10:28 PST

Investigating

The UPS API is experiencing high rates of errors and timeouts for rating and labels. UPS has been notified and our engineers will continue to monitor the performance of the UPS API.
Posted Nov 29, 2023 - 09:49 PST
This incident affected: Carriers (UPS, UPSDAP, UPS SurePost, UPS Mail Innovations).