We have scheduled maintenance that will affect Veho’s performance.

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 08:22 PDT

Monitoring

The Veho carrier is currently undergoing a change in their API which will bring down our service with Veho temporarily. We are expecting this maintenance to finish around 8AM PST on April 1, 2025.
Posted Mar 31, 2025 - 18:51 PDT