Elevated FedEx Error Rate
Incident Report for EasyPost
Resolved
There have been no further FedEx errors in the last half-hour. Everything is stable at this time.
Posted Jul 22, 2020 - 17:04 PDT
Monitoring
FedEx appears to have fixed the problems they were experiencing. EasyPost engineers will continue to monitor.
Posted Jul 22, 2020 - 16:48 PDT
Investigating
We are currently seeing an elevated error rate from FedEx. Engineers are investigating, but at this time we believe the problem is on FedEx's end.
Posted Jul 22, 2020 - 16:01 PDT
This incident affected: EasyPost Backend (API).