UPS performance issues

Incident Report for EasyPost

Resolved

UPS performance has returned to normal.
Posted Jun 05, 2025 - 12:01 PDT

Investigating

EasyPost is seeing issues with the UPS. We are investigating and communicating with UPS and will provide updates. We apologize for the inconvenience.
Posted Jun 05, 2025 - 11:37 PDT
This incident affected: Carriers (UPS, UPSDAP).