Degraded performance for DHL eCommerce
Incident Report for EasyPost
Resolved
Everything's been stable for the last 90 minutes; this incident is resolved.
Posted Sep 08, 2021 - 17:54 PDT
Monitoring
DHL eCommerce performance has returned to normal as of approximately 16:20 Pacific time. Engineers continue to monitor the situation.
Posted Sep 08, 2021 - 16:34 PDT
Identified
Upstream DHL performance for shipment purchases is still showing degraded performance; rating and tracking do not seem to be affected at this time.
Posted Sep 08, 2021 - 15:56 PDT
Investigating
We are currently experiencing timeouts and degraded performance contacting DHL eCommerce. Engineers are investigating.
Posted Sep 08, 2021 - 14:14 PDT
This incident affected: EasyPost Backend (API).