UPS Performance Issues

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 19:45 PDT

Investigating

EasyPost is seeing issues with the UPS. We are investigating and communicating with UPS and will provide updates. We apologize for the inconvenience.
Posted Jun 18, 2025 - 12:10 PDT
This incident affected: Carriers (UPS).