UPS MI performance issues

Incident Report for EasyPost

Resolved

The UPS MI service has been stable since 6:17 PM PST. We consider this
incident resolved but will continue to monitor its performance.
Posted Jan 17, 2025 - 04:50 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 16, 2025 - 18:28 PST

Investigating

EasyPost is seeing issues with the UPS MI. We are investigating and communicating with UPS and will provide updates. We apologize for the inconvenience.
Posted Jan 16, 2025 - 12:15 PST
This incident affected: Carriers (UPS Mail Innovations).