USPS Label Broker® Outage

Incident Report for EasyPost

Resolved

This incident has been resolved, and we are seeing successful requests to the USPS Label Broker® service.
Posted Jun 09, 2023 - 06:54 PDT

Monitoring

USPS has confirmed a fix has been implemented and we are monitoring the results.
Posted Jun 09, 2023 - 05:51 PDT

Identified

The USPS has acknowledged that and the USPS IT team is working on a resolution.
Posted Jun 09, 2023 - 05:04 PDT

Investigating

Engineers are currently investigating an outage with the USPS Label Broker® service.
Posted Jun 09, 2023 - 04:10 PDT
This incident affected: Carriers (USPS).