Major network issues
Incident Report for EasyPost
Resolved
Everything has been stable for the last hour; we're considering this incident resolved at this time.
Posted Dec 15, 2021 - 09:57 PST
Update
Everything has been stable for the last hour; we're considering this incident resolved at this time.
Posted Dec 15, 2021 - 09:56 PST
Monitoring
There was another brief spike of connectivity issues to AWS, but it's resolved. Engineers continue to monitor.
Posted Dec 15, 2021 - 08:51 PST
Investigating
AWS performance appears to be degrading again. Engineers are investigating.
Posted Dec 15, 2021 - 08:48 PST
Monitoring
All services have been operational since approximately 07:50 Pacific time. Engineers continue to monitor.
Posted Dec 15, 2021 - 08:17 PST
Investigating
There appears to be an outage occurring across west-coast AWS regions. This is not directly affecting EasyPost, but is preventing us from reaching many carriers and causing overall degraded performance. Engineers are investigating.
Posted Dec 15, 2021 - 07:16 PST
This incident affected: EasyPost Backend (Webhooks, API, Tracking) and Website.