Scheduled USPS API Maintenance

Scheduled for Sep 24, 18:00 - 22:00 PDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 23, 2026 - 12:41 PDT

Scheduled

USPS will perform scheduled API maintenance beginning Thursday, September 24 at 9:00 PM ET (6:00 PM PT) and concluding Friday, September 25 at 1:00 AM ET (10:00 PM PT). During this window, EasyPost customers may experience intermittent service degradation, including increased latency or brief disruptions when purchasing USPS domestic and international shipping labels. USPS rating and pricing services are not expected to be affected.
Posted Sep 23, 2026 - 11:45 PDT
This scheduled maintenance affects: Label Purchases (USPS Postage Purchases) and Carriers (USPS APIs).