Delays updating FedEx trackers
Incident Report for EasyPost
Resolved
We have improved our FedEx tracking integration, although we're still seeing errors from the FedEx side. Trackers should update over the next few hours.
Posted Apr 22, 2020 - 19:20 PDT
Investigating
We are currently seeing issues updating some FedEx trackers. Engineers are investigating.
Posted Apr 22, 2020 - 10:22 PDT
This incident affected: EasyPost Backend (Tracking).