DNS Issues
Incident Report for EasyPost
Resolved
This incident is resolved.
Posted Oct 22, 2019 - 21:58 PDT
Investigating
Some customers may have difficulty accessing label images due to an underlying issue with AWS's Route53 DNS service. This only affects label image download; labels purchased at this time are being saved correctly and can be downloaded later. You can monitor outage status directly at https://status.aws.amazon.com
Posted Oct 22, 2019 - 13:13 PDT