USPS Trackers Not Updating
Incident Report for EasyPost
Resolved
USPS tracking data is fully restored.
Posted Jul 12, 2022 - 21:20 PDT
Update
The backfill is continuing to run. All tracking data is expected to be fully restored by this evening.
Posted Jul 12, 2022 - 12:55 PDT
Update
The backfill is continuing to run. Tracking data is expected to be fully restored by tomorrow evening.
Posted Jul 11, 2022 - 17:54 PDT
Monitoring
A fix has been implemented and USPS tracking details are beginning to backfill. Engineers are continuing to monitor the results.
Posted Jul 11, 2022 - 12:20 PDT
Investigating
We are receiving reports that USPS trackers are not updating. We have identified the cause of the outage and are actively communicating with the USPS to resolve the issue.
Posted Jul 11, 2022 - 11:33 PDT
This incident affected: EasyPost Backend (Tracking).