Elevated 5XX responses

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Apr 28, 2026 - 08:57 PDT

Monitoring

The underlying issue has been mitigated and we are monitoring
Posted Apr 28, 2026 - 06:01 PDT

Identified

We have identified the underlying issue and are working on resolving it
Posted Apr 28, 2026 - 04:13 PDT
This incident affected: EasyPost Backend (API, Tracking, Address Verification).