Issues purchasing FedEx Ground labels

Incident Report for EasyPost

Resolved

This incident has been resolved by FedEx.
Posted May 22, 2024 - 11:56 PDT

Investigating

We are currently investigating issues purchasing FedEx Ground labels.
Posted May 22, 2024 - 10:15 PDT