UPS Mail Innovations Shipping Label Issues

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Jun 07, 2024 - 09:04 PDT

Monitoring

The issue appears to be resolved. We are monitoring to ensure shipping labels are valid.
Posted Jun 06, 2024 - 15:44 PDT

Identified

EasyPost has identified an issue due to a recent UPS change that may temporarily affect some of our users ability to print UPS MI shipping labels. We are communicating with UPS and will provide updates as a fix is released by UPS.
We apologize for the inconvenience.
Posted Jun 06, 2024 - 10:46 PDT
This incident affected: Carriers (UPS Mail Innovations).