FedEx experiencing elevated error rate with label buys

Incident Report for EasyPost

Resolved

FedEx API has remained stable and error rates have been at normal levels for over an hour. Incident appears to be resolved.
Posted Aug 25, 2025 - 07:51 PDT

Monitoring

Our investigation has confirmed the issue was with the carrier servers/APIs, and appears to now be resolved on the FedEx side. Error rates are back to normal levels. We will continue to monitor.
Posted Aug 25, 2025 - 06:37 PDT

Investigating

We are investigating FedEx API issues with label buys.
Posted Aug 25, 2025 - 06:28 PDT
This incident affected: Carriers (FedEx, FedEx SmartPost).