Ontrac Carrier Degraded Performance

Incident Report for EasyPost

Resolved

The carrier appears to have recovered. Engineers will continue to monitor its performance.
Posted Mar 31, 2022 - 09:46 PDT

Update

We are continuing to monitor this issue
Posted Mar 31, 2022 - 09:37 PDT

Identified

OnTrac Shipping and Tracking services are currently offline. Engineers are continuing to monitor the situation.
Posted Mar 31, 2022 - 06:45 PDT
This incident affected: Carriers (Ontrac).