Customers are currently unable to add Bank Accounts through their EasyPost dashboard

Incident Report for EasyPost

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2026 - 12:24 PDT

Identified

Our payment provider has made an unexpected change, we are working with them to resolve the issue.
Posted Apr 03, 2026 - 11:01 PDT
This incident affects: Stripe API.