USPS Label Broker Outage

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Oct 29, 2024 - 21:32 PDT

Monitoring

The USPS Label Broker service is down for maintenance. Service should be restored by 1:00AM ET.
Posted Oct 29, 2024 - 19:11 PDT

Investigating

An outage is being investigated with the USPS Label Broker service.
Posted Oct 29, 2024 - 18:39 PDT
This incident affected: Carriers (USPS).