UPS partial outage

Incident Report for EasyPost

Resolved

This incident has been resolved.
Posted Sep 21, 2025 - 07:41 PDT

Monitoring

The connectivity issue between EasyPost and UPS has improved. Response times and error rates are back to normal. We are continuing to monitor.
Posted Sep 20, 2025 - 22:53 PDT

Investigating

The EasyPost engineering team is currently investigating an issue affecting UPS operations for some customers.
Posted Sep 20, 2025 - 21:48 PDT
This incident affected: Carriers (UPS, UPSDAP, UPS SurePost, UPS Mail Innovations).