USPS Label Buys

Incident Report for EasyPost

Resolved

USPS label buys have returned to normal operation.
Posted Jul 09, 2025 - 06:40 PDT

Update

Issues with USPS label buys have been addressed. The EasyPost team continues to monitor at this time.
Posted Jul 09, 2025 - 06:14 PDT

Monitoring

Mitigations are in place. We are continuing to monitor it.
Posted Jul 09, 2025 - 04:55 PDT

Investigating

We are experiencing elevated response times with USPS label buys. The issue is being investigated by Engineering
Posted Jul 09, 2025 - 04:45 PDT
This incident affected: Label Purchases (USPS Postage Purchases).