Payment Issues
Incident Report for EasyPost
Resolved
This has been resolved
Posted Oct 20, 2020 - 13:22 PDT
Investigating
Engineers are investigating a possible outage with our payment processor, Stripe.
Posted Oct 20, 2020 - 11:33 PDT
This incident affected: Stripe API.