Connectivity Issues
Incident Report for EasyPost
Resolved
Everything has been stable for approximately 15 minutes.
Posted Jul 17, 2020 - 14:59 PDT
Monitoring
We believe that this issue is resolved, but are still monitoring.
Posted Jul 17, 2020 - 14:48 PDT
Investigating
EasyPost is experiencing connectivity issues to several downstream carriers. We believe that this is an outage of a service provider used by those carriers, but engineers are investigating. Users may see an elevated error rate for rating and purchasing of the affected labels.
Posted Jul 17, 2020 - 14:29 PDT
This incident affected: EasyPost Backend (API, Tracking).